The resultLimit makes people think that it is going to throw when the limit is reached. So rename it to PageSize instead to reflect that it is going to chunked the results.
Comments: Fixed: http://aspnetwebstack.codeplex.com/SourceControl/changeset/0d273618b99e
Comments: Fixed: http://aspnetwebstack.codeplex.com/SourceControl/changeset/0d273618b99e